Redhat 5.2 with 3c905 not working

Sidharth Kshatriya
Sat Jan 30 16:58:08 1999


I am running Linux 2.0.36 on a Dell 266 Pentium II. I have been trying to
get my 3c905-TX card to work for many months now. I am running Redhat 5.2.

1. I have the latest version of the linux driver dated 11/17/98
2. The card works perfectly in Windows NT/98
3. I have tried moving around the card on different slots in the machine
4. I have recompiled my kernel several times to ensure that nothing is
corrupted in the code
5. I have been through many complete reinstalls of linux
6. The card is recognized properly but it simply won't work. When I try to
ping / use the network it hangs
7. I have tried to mess around *a lot* with the kernel routing table with
no effects
8. On one or two occasions the card has worked but on rebooting it hasn't.
The card for some random reason works and I have not been able to replicate
the situation when it worked.
9. I have tried all sort of combinations like booting into dos then
starting linux and running 3com supplied software to initialize the card.
At the moment the card has been forced into 10 Base T mode using the 3com
10. Enlisted the help of an experience linux user -- with no results
11. Tried to cold boot my machine

After doing all of the above I have still not been able to get the card to
work. Please help!

Sidharth Kshatriya