[tulip] PCMPC200 v2 gives Unresolved Symbols on 2.4.7-10

Andrea Lamorgese andreala@eccentric.mae.cornell.edu
Sat Aug 24 23:38:01 2002

Hello everybody,

I cannot get my Linksys PCMPC200 v2 CardBus card to work
(on an HP Omnibook XE3-L with Redhat 7.2 -- 2.4.7-10):
after reading one of the messages (by J.A. Pfeil,
Unresolved symbols w. 2.4.7), I tried with netdrivers.tgz
and then make && make install.
Compilation was smooth and insmod pci_scan.o also was, but as
soon as I try --> insmod tulip.o -->  I get

tulip.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.

But the above is wrong, right? Then, I tried
make tulip_cb.o  --> compilation is okay (no messages).

When I try:  insmod tulip_cb.o  then
tulip_cb.o: unresolved symbol register_driver_Ra8664c22
tulip_cb.o: unresolved symbol unregister_driver_R9e54a5d8

I did not forget to modify /etc/pcmcia/config
with the manfid as on Linksys website:


but, of course, this is not very important unless the
problem with the unresolved symbols can be solved.

Suggestions of any kind would be greatly appreciated!

Thank you for being out there!

Andrea G. Lamorgese