[tulip] PCMPC200 v2 gives Unresolved Symbols on 2.4.7-10

Donald Becker becker@scyld.com
Sun Aug 25 12:27:01 2002

On Sat, 24 Aug 2002, Andrea Lamorgese wrote:

> I cannot get my Linksys PCMPC200 v2 CardBus card to work
> (on an HP Omnibook XE3-L with Redhat 7.2 -- 2.4.7-10):
> after reading one of the messages (by J.A. Pfeil,
> Unresolved symbols w. 2.4.7), I tried with netdrivers.tgz
> and then make && make install.
> Compilation was smooth and insmod pci_scan.o also was, but as
> soon as I try --> insmod tulip.o -->  I get
> tulip.o: init_module: No such device

The driver didn't find a recognized card.

> But the above is wrong, right? Then, I tried
> make tulip_cb.o  --> compilation is okay (no messages).

Using drivers compiled to '*_cb.c' is unlikely to work with a standard
Red Hat 7.2 system.  That distribution uses only in-kernel CardBus drivers.

> I did not forget to modify /etc/pcmcia/config
> with the manfid as on Linksys website:
> http://www.linksys.com/support/support.asp?spid=26

Errrmm, what line did you put in the config file?

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993