[tulip] LNE100TX v2

Ben Gelb ben@gelbnet.com
Sat Aug 24 12:35:01 2002

We are imaging a computer lab at my school using SystemImager (which
uses rsync).

Most of our machines worked fine, but we have 25 machines with
LNE100TXv2 cards. These have had a problem.

When we try to image a computer with that type of card, it goes unusably
slow. The image usually takes less than 10 minutes to copy. On an
LNE100TX machine we have left it overnight and it is not done.

We discovered that by connecting a hub inbetween the computer and the
lab's switch (thus forcing the card into half-duplex mode) it runs fine.

I have been trying to figure out how to make it link in half-duplex mode
without having to connect a hub in this fashion.

I have tried passing kernel options in the bootloader, tried it as a
module and passing options there, and tried directly editing the source

The kernel options in LILO (append="ether......") seem to be ignored. As
a module, or by directly editing the source code, the options seem to
get some response. I can force the card into 10baseT mode, BUT, then it
will not link. If I bring the interface up and ping something, the
activity light blinks on the back, but it doesn't link up to the
network. VERY odd.

I am using the tulip driver included with the 2.4.18 kernel. 

Any help would be greatly appreciated.