[tulip] error messages after trying to compile

Donald Becker becker@scyld.com
Sat, 17 Mar 2001 21:32:30 -0500 (EST)

On Fri, 16 Mar 2001 DB1029@aol.com wrote:

> Alright i've been having problems compiling my tulip.c driver for my lne100tx 
> nic(off the second disk) running mandrake 7.0.

Are you trying to use the driver included with the card?  It's probably
easier to use the RPM

  rpm -i ftp://ftp.scyld.com/pub/network/netdriver-2.1.src.rpm
  cd /usr/src/redhat/
  rpm -bb SPECS/netdriver.spec
  rpm -i --force RPMS/i386/netdriver*.i386.rpm
> I've tried to follow the nhf 
> and read the tulip mailing list archive about a dozen times. When i ran the 
> command using the recommended dir it gave me the same errors and i searched 
> for the missing files and most of them where in "i586-glibc20-linux" so i 

No, that's the wrong include directory.
Those include files are not correct for kernel modules.
Your kernel include files should be at
If they are not, verify that you installed the kernel package.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993