[tulip] error messages after trying to compile

Brian Rogers w006552@airmail.net
Sat, 17 Mar 2001 08:56:17 -0600 (CST)

On Fri, 16 Mar 2001 DB1029@aol.com wrote:

> Alright i've been having problems compiling my tulip.c driver for my
> lne100tx nic(off the second disk) running mandrake 7.0. I've tried to
> follow the nhf and read the tulip mailing list archive about a dozen
> times. When i ran the command using the recommended dir it gave me the
> same errors and i searched for the missing files and most of them
> where in "i586-glibc20-linux" so i just plugged that in. I'm thinking
> i don't have something installed or something thanks.
> [root@powerhouse tmp]# gcc -DMODULE -D KERNEL -Wall -Wstrict-prototypes -O6 -c
> tulip.c '[ -f /usr/i586-glibc20-linux/include/linux/modversions.h ] && echo
> gcc: [ -f /usr/i586-glibc20-linux/include/linux/modversions.h ] && echo
> -DMODVERSIONS: No such file or directory

Ignore everything after the first error.  You put regular single-quotes
around the -f test.  I'm guessing you meant to put back-ticks around it.
Like this:

	gcc -DMODULE -D KERNEL -Wall -Wstrict-prototypes -O6 -c tulip.c
	`[ -f /usr/i586-glibc20-linux/include/linux/modversions.h ] &&

If your shell is bash, I recommend avoiding this confusion by using $()
instead of back-ticks.  Like this:

	gcc -DMODULE -D KERNEL -Wall -Wstrict-prototypes -O6 -c tulip.c
	$([ -f /usr/i586-glibc20-linux/include/linux/modversions.h ] &&

/* Brian Rogers, professional geek, coffee achiever */