[tulip] More on turning off autosense issue

Chris North chris@mazunetworks.com
Wed, 25 Apr 2001 19:14:15 -0400

Continuing on the my previous post regarding problems turning off
autosense for a Znyx ZX346Q under Red Hat 7.0. I took the suggestion of
using a loadable module instead of the built-in driver. Unfortunately
that doesn't appear to work either. I set it as a loadable module and
put this 

alias eth1 tulip 
options tulip options=5

When I run either mii-diag or tulip-diag it reports back that
auto-negotiate is on. I also tried setting the options on the command
line and it doesn't work either. Here's the output of that: 

  root@chavez-ravine% insmod tulip options=5,5
  Using /lib/modules/2.2.18-m1/net/tulip.o
  root@chavez-ravine% /tmp/mii-diag
  Using the default interface 'eth0'.
  Basic registers of MII PHY #1:  3000 782d 02a8 0154 05e1 45e1 0001
   Basic mode control register 0x3000: Auto-negotiation enabled.
   You have link beat, and everything is working OK.
   Your link partner advertised 45e1: Flow-control 100baseTx-FD
100baseTx 10baseT-FD 10baseT, w/ 802.3X flow

However if I turn off auto-negotiation using mii-diag, that works.
Anyone have any ideas as to why the modules.conf method doesn't work and
mii-diag does? 

Thanks in advance...