[tulip] Installation - Linksys Ethercard, round 2

Donald Becker becker@scyld.com
Thu, 12 Apr 2001 09:45:46 -0400 (EDT)

On Thu, 12 Apr 2001, Matthew O. Persico wrote:

> DSL Router, also serving as the DHCP server and the firewall (it's a
> Zyxel Prestige 641, in case anyone is interested) at address
> LinkSys PrintServer/4port Hub at

Is this a repeater, a dual speed repeater, or a switch?

> Mandrake 7.2 box at using a LinkSys LNE 10/100 ethercard

Which card?
What is the detection message?

> The Mandrake box can ping everyone EXCEPT the DSL Router. Pinging
> hangs. Which would explain why DCHP doesn't fly. :-(
> I think the problem is that the NT connection is 10MB/half duplex
> whereas the Mandrake connection lights up the 100MB and full duplex
> lights on the Hub.

If there is a full duplex light on the hub, that likely means that it's
a switch.

> Seems to me I need to get the card into 10MB, half duplex mode before I
> have a prayer of fixing anything else.

I suspect that this isn't your problem.

> First I tried to use the SRPMs at
> http://www.scyld.com/network/tulip.html. Finally, I downloaded the
> individual files (tulip.c, pci-scan.[ch] and kernel*.h), compiled and
> tried to install them. No dice. It seems that these lines in
> /etc/modules.conf are not being accepted
> alias eth0 tulip
> options tulip full_duplex=0 options=1 debug=6

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993