[tulip] Linksys NC100 w/ RH7 - Linux Newbie Question

Liam McCusker liam@transmitliam.com
Fri, 6 Apr 2001 11:44:58 -0400

I was thinking that there might have been a problem with my last e-mail to
the list, so I thought I'd try asking again.  I'm really desperate as I'm
using WinME to connect to my cable provider at this particular time - and
like a good deal of people these days, am completely sick of Windows and

So, I have two Linksys NC100 cards in my serving machine (for local
network).  I know this isn't the smartest thing to have done, but like I
said in the subject, I'm a newbie.  :o)

After all kinds of searching, I finally found scyld.  I've printed out and
gone over a few pages of the tulip and network setup tutorials on the site
and have tried them without success.

First I ran a compile command that I found on an unrelated (non-tulip) page
of the site and came up with all kinds of errors.  So I then went through
and found the tulip compile commands at the end of the file.  So I tried
with gcc and as you would expect, came up with the errors you mention in
regards to RedHat 7 and compiling.  After finding that particular note about
RedHat7, I tried again using kgcc and actually had a *.o file!!  Woo Hoo!

However, after trying to install it into the system (was actually
modules.conf), still wouldn't work.

Something of note, however.  I received several errors during compile that I
didn't really notice until the second try.  Please remember that I'm now on
WinME, so I wasn't able to copy them for you to see, however I'll do my best
to describe them.  In several different parts of the compile output I
received warnings that *.h file was changed.  At the end of the compile it
claimed that there was a "fatal"(not sure if that's the exact term used)
error with kgcc where it couldn't continue or something like that.

I'm assuming that this is why my driver won't work.  However, I also
discovered thanks to the RH.install newsgroup that there's a tulip driver
installed with the system.  If that's not the right driver, then I don't
feel so bad.

But I would like to know your oppinion.  Should I just reinstall the system
to have all those *.h files reverted to their original state?  Or should I
try again using a different set of methods in order to install?

I greatly appreciate your time and help.  This, by the way, is for the
purpose of helping me understand Linux better as well as other server
applications to further my web development skills, so you can see how
important this is for me.

Thanks again.


Liam McCusker