Multiple PCI devices on the same IRQ: kernel or driver?

Thu Jan 14 14:44:56 1999

On Mon, 30 Nov 1998 15:57:51 -0500 (EST), Donald Becker wrote:

>On Mon, 30 Nov 1998, Mark Martin wrote:
>> I recently purchased a Netgear FA310TX card and have been having the
>> same problem as Erik Beck, namely my BIOS insists on putting all of my
>> PCI devices on IRQ 10 and does not give me any control over the
>> situation.  Consequently, whenever I try to bring the interface up, I am
>> greeted with the error message
>> SIOCSIFFLAGS: Resource temporarily unavailable
>> There has been a fair amount of traffic on the mailing list about Erik's
>> problem.  Erik indicated that he had been advised that sharing an IRQ
>> under Linux was "not a good idea".
>It is OK.  It works well.
>> Jon Lewis suggested that the kernel
>> does a poor job of IRQ sharing but suggested hacking the tulip driver. 
>NOoooo.  Hack the driver that's causing the problem.
>It's likely a SCSI driver.
>> David ( implicated the kernel when he mentioned
>> that he has no trouble sharing an IRQ and credited the development
>> kernels that he runs.
>No, PCI IRQ sharing has worked since 1.1.73 or so.
>Donald Becker
>USRA-CESDIS, Center of Excellence in Space Data and Information Sciences.
>Code 930.5, Goddard Space Flight Center,  Greenbelt, MD.  20771

IRQ sharing not a problem:

 know that this chipset is not to highly recommended on the drivers site but I gave up on my tulip card and 
bought a Realtek 8139 10/100 card for 14 $ at a computer show (they had hundreds) the thing made by 
encore (enl832-tx) worked right out of the box. Furthermore the driver disk came with the linux drivers source 
and a reference to the linux driver site at I have never had overflow or timeout errors. Although I'm 
not able to really stress the card since all i'm running is a home network of four computers. the card is installed 
on a server that uses diald, squid, and ip masquerading to connect the systems to the net via one dialup line. 
It also implements vgetty on my voice line. I have run the card at 100 and 10 mbp  without problems. The 
server is Debian 2.0 it has had kernels 2.0.34 and now runs 2.0.36 .  The card is sharing irq 11 without any 
problems. I actually did not mean to set it up this way but since i didn't bother changing the bios settings and 
everything worked i just left it as is. BTW i dont think this is a real sign of performance but the realtek card 
handled a remote install of Redhat 5.1 on one machine and windows 98 on another without flaw using samba 
sharing the wo cdrom drives.

- Richard Reyes