NetGear FA310TX Problems

Wed Dec 2 01:18:44 1998

I encountered a similar problem when I tried to compile the patched version 89k that I got from the site. I then tried thier alternate suggestion of copying tulip.c into the linux/drivers/net directory and setting the kernel configuration to build the tulip driver as a module. This worked with the 2.1.130 kernel, and the resulting tulip.o module worked, establishing a 100 MB/s full-duplex connection. I was also able to build tulip.o is a separate directory by using the same gcc command that the kernel makefile had produced.

I plan to try the same test with the 2.0.36 kernel. I'll post the results when they are available.

-----Original Message-----
From:	Joshua Jackson []
Sent:	Tuesday, December 01, 1998 9:58 PM
Subject:	NetGear FA310TX Problems

Hey, I have a NetGear FA310TX NIC and I have 5 different versions of
tulip.c (slack version, NetGear version, and three from your web-site).
Everytime I try to compile them I get the same error.
Likewise, when I try to rebuild my kernel, the same thing happens...

mother:/# gcc -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall
-Wstrict-prototypes -O6 -c tulip.c
/usr/include/asm/string.h: In function `__constant_memcpy':
In file included from /usr/include/linux/string.h:39,
                 from /usr/include/asm/termios.h:58,
                 from /usr/include/linux/termios.h:5,
                 from /usr/include/linux/tty.h:20,
                 from /usr/include/linux/sched.h:26,
                 from tulip.c:87:
/usr/include/asm/string.h:443: warning: control reaches end of non-void
function/usr/include/asm/string.h: In function
/usr/include/asm/string.h:594: warning: control reaches end of non-void

Do you think there is something messed up with the string.h?  I even
reformatted and re-installed slack from the CD.  I'm running 2.0.34 (off

the slack 3.5 cd from CheapBytes).  I'm guessing that it's a compile
problem, 'cuz it seems as though I'm doing everything the texts say to
do.  I do get a tulip.o after the compile.
I've tried rebuilding the kernel with ethernet support, loading it in
rc.module and rc.inet1.  If you can think of anything, please tell me.