[realtek] Same problem as Mr. Dante Plicato

Donald Becker becker@scyld.com
Wed Mar 6 18:13:01 2002

On Wed, 6 Mar 2002, Stephan Elsner wrote:

> >> pcmcia_cs - 3.1.31
> >
> >I suspect that something has changed with this version of pcmcia_cs.
> Mr. Plicanto tried several versions with the same result...
> >>         I/O ports at <unassigned> [disabled]
> >>         Memory at <ignored> (32-bit,non-prefetchable)
> >>         Capabilities: [50] Power Management version 2
> >
> >Here is the problem: the resources have not been assigned by the PCMCIA
> >code.
> Ok, but why? A 16 bit PCMCIA modem card works well...

There are different code paths for 16 bit (somewhat ISA-like) and 32 bit
cards.  32 bit Cardbus cards are almost identical to PCI cards, even
using the same chips.

> >> Ok, older rtl8139.c because I could neither compile the version from
> >> the "test" directory nor the one from the directory above. 
> >
> >What was the compile problem?
> Hmm, I'd need to type the error messages (no network, no floppy) they are 1186 lines.
> So I took some screen shots (with my camera ;-) and put them on
> http://www.elsni.de/error/

Did you use the Makefile, or compile by hand?
The /usr/src/pcmcia/include path doesn't seem to have valid include files.

Note: You don't need to be root to compile, only to install and load modules.

> >> I tried both bios settings PnP-OS yes/no with no effect. It seems that
> >> the bios (Phoenix) doesn't assign an IRQ to the card at all. 
> >
> >For CardBus card the BIOS settings are not important.
> You told other people to deactivate the PnP bios option, what's that for then?

That's for cards in PCI slots, which we expect will have resources
assigned by the BIOS.  The 2.2 kernel doesn't have resource assignment
code (the 2.4 kernel now does).

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993