[realtek] Same problem as Mr. Dante Plicato

Stephan Elsner elsni@elsni.de
Wed Mar 6 17:55:01 2002

Thank you for your answer!

>> pcmcia_cs - 3.1.31
>I suspect that something has changed with this version of pcmcia_cs.

Mr. Plicanto tried several versions with the same result...

>>         I/O window 0: 00000000-00000003
>>         I/O window 1: 00000000-00000003
>Hmmm, these I/O windows are suspicious.
>> 20:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RT8139 (rev10)
>>         Subsystem: Billionton Systems Inc: Unknown device 0200
>>         Flags: medium devsel
>>         I/O ports at <unassigned> [disabled]
>>         Memory at <ignored> (32-bit,non-prefetchable)
>>         Capabilities: [50] Power Management version 2
>Here is the problem: the resources have not been assigned by the PCMCIA

Ok, but why? A 16 bit PCMCIA modem card works well...

>> Mar  4 21:40:11 debian kernel: rtl8139.c:v1.12 9/14/2000 Donald Becker, becker@scyld.com.
>> Mar  4 21:40:11 debian kernel: http://www.scyld.com/network/rtl8139.html
>> Mar  4 21:40:11 debian cardmgr[158]: get dev info on socket 0 failed: Resource temporarily unavailable
>This is reporting that even the 'cardmgr' program in the PCMCIA code
>couldn't use the interface.
>I believe that you'll need to get a different PCMCIA package, either
>older or newer.

I'll try the newer one, and tell you the results

>> Ok, older rtl8139.c because I could neither compile the version from
>> the "test" directory nor the one from the directory above. 
>What was the compile problem?

Hmm, I'd need to type the error messages (no network, no floppy) they are 1186 lines.
So I took some screen shots (with my camera ;-) and put them on

>> I tried both bios settings PnP-OS yes/no with no effect. It seems that
>> the bios (Phoenix) doesn't assign an IRQ to the card at all. 
>For CardBus card the BIOS settings are not important.

You told other people to deactivate the PnP bios option, what's that for then?