[realtek] Can't load RTL8139.o module Rhat 7.0

Mariano Mendez mmendez@fcaglp.unlp.edu.ar
Wed, 15 Nov 2000 19:32:57 -0300 (ARST)


I have a PCMCIA Ethernet Card L100C32 2 10/100 Mbps 32 bits from
Dynalink. I'm trying to make it work on a Sony VAIO SR1K running
Redhat 7.0, kernel 2.2.16-22 using pcmcia-cs-3.1.22.

I'm unable to make the card work (the card does not seem to be
broken; it works in Windows 2000). I mailed the company, and
they say that the card is a Realtek chipset base card with the
card ID and the settings activated into the scripts, and that I
should download the latest driver from the net.

I have rtl8139.o from pcmcia-cs, which I guess is what I need.
After boot up I tried ifconfig, and I only get the output for
'lo'. If I try ifconfig eth0 I get 'Device not found'.

I first tried without defining the module in /etc/modules.conf.
Later on I added "alias eth0 rtl8139", but nothing changed.

lsmod shows me this:

Module                  Size  Used by
nfs                    28768   1  (autoclean)
ds                      6248   1 
i82365                 22512   1 
pcmcia_core            44768   0  [ds i82365]
lockd                  31176   1  (autoclean) [nfs]
sunrpc                 52964   1  (autoclean) [nfs lockd]
agpgart                18600   0  (unused)
nls_cp437               3876   4  (autoclean)
vfat                    9404   2  (autoclean)
fat                    30688   2  (autoclean) [vfat]

When I try to load the module manually using modprobe I get:

[root@pan /root]# modprobe rtl8139
/lib/modules/2.2.16-22/net/rtl8139.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including inva
lid IO or IRQ parameters
/lib/modules/2.2.16-22/net/rtl8139.o: insmod /lib/modules/2.2.16-22/net/rtl8139.
o failed
/lib/modules/2.2.16-22/net/rtl8139.o: insmod rtl8139 failed

>From /proc/pci I see:

PCI devices found:
  Bus 32, device   0, function  0:
    Ethernet controller: Realtek Unknown device (rev 16).
      Vendor id=10ec. Device id=8138.
      Medium devsel.  Fast back-to-back capable.  

I would appreciate if any of you can help me on this one. I tried
several HOWTO's, mailing lists, etc., but so far I could not find
the solution. 

Below there are a couple of logs that I hope could be useful.



This is from /var/log/messages when I insert or eject the card:

Nov 15 18:19:25 pan kernel: cs: cb_free(bus 32)
Nov 15 18:19:28 pan cardmgr[443]: initializing socket 0
Nov 15 18:19:28 pan cardmgr[443]: unsupported card in socket 0
Nov 15 18:19:28 pan kernel: cs: cb_alloc(bus 32): vendor 0x10ec, device 0x8138
Nov 15 18:19:29 pan cardmgr[443]:   product info: "PCMCIA", "CardBus Ethernet 10
/100 (R5)"
Nov 15 18:19:29 pan cardmgr[443]:   manfid: 0x0260, 0x0235  function: 6 (network
Nov 15 18:19:29 pan cardmgr[443]:   PCI id: 0x10ec, 0x8138
Nov 15 18:20:00 pan CROND[721]: (root) CMD (   /sbin/rmmod -as) 

This from dmesg:

Linux version 2.2.16-22 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Tue Aug 22 16:49:06 EDT 2000
Detected 494276 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 986.32 BogoMIPS
Memory: 62872k/65472k available (1048k kernel code, 412k reserved, 1076k data, 64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 65536 (order 6, 256k)
Page cache hash table entries: 16384 (order 4, 64k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium III (Coppermine) stepping 03
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfd9be
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Enabling memory for device 00:40
PCI: Enabling I/O for device 00:48
PCI: Enabling I/O for device 00:50
PCI: Enabling memory for device 00:50
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 65536 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfcf0-0xfcf7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfcf8-0xfcff, BIOS settings: hdc:pio, hdd:pio
hda: IBM-DARA-209000, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: IBM-DARA-209000, 8623MB w/418kB Cache, CHS=1099/255/63
Floppy drive(s): fd0 is 1.44M
floppy0: no floppy controllers found
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :  1099.566 MB/sec
   p5_mmx    :  1154.811 MB/sec
   8regs     :   848.868 MB/sec
   32regs    :   475.869 MB/sec
using fastest function: p5_mmx (1154.811 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: hda1 hda2 hda3 hda4 < hda5 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 176672k swap-space (priority -1)
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 27M
agpgart: Detected Intel 440BX chipset
agpgart: AGP aperture is 16M @ 0x40000000
Linux PCMCIA Card Services 3.1.22
  kernel build: 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000
  options:  [pci] [cardbus] [apm]
PCI routing table version 1.0 at 0xfdf60
Intel PCIC probe: 
  Ricoh RL5C475 rev 80 PCI-to-CardBus at slot 00:0c, mem 0x68000000
    host opts [0]: [isa irq] [io 3/6/1] [mem 3/6/1] [pci irq 9] [lat 168/176] [bus 32/34]
    ISA irqs (default) = 3,4,5,7,10,11,12,15 PCI status changes
cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x170-0x177 0x220-0x22f 0x330-0x337 0x370-0x377 0x388-0x38f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: cb_alloc(bus 32): vendor 0x10ec, device 0x8138

					     Mariano Mendez