Epic100 problems.

Erich Reitz ereitz@usa.net
Thu Mar 11 12:50:16 1999


I just wanted to add my voice to the epic100 problem list.  I don't know if I 
am experiencing a single or many problems related to the epic100.c driver. I'd 
glady appreciate any advice.

I have been using the epic100 driver previous to version 1.0 at which time I 
was unable to run at 100 Tx FD due to Trasmit Timeout errors. I had to force 
it to 10Mb.  Now at driver version 1.06 I am able to run at 100 but still 
experience other problems.  The card is in a Linux 2.0.35 box running along 
side a generic 10baseT NE2000 card (which never has any problems).

My standard boot processes adds the following to the log. I run the Linux box 
directly connected via crossover cable to an NT box with a duplicate SMC 
9432TX card (which does not experiences problems).

eth1: SMSC EPIC/100 83c170 at 0xf800, IRQ 10, 00:e0:29:0a:ec:de. 
eth1: MII transceiver #3 control 3000 status 7809. 
eth1:  Autonegotiation advertising 01e1 link partner 0001. 
eth1: Setting full-duplex based on MII #3 link partner capability of 41e1. 

Many times during boot the above will be in my log, but I will be unable to 
ping the NT machine.  However on the NT machine using the SMC Diagnostics 
service I am able to see the pings being received and the ping replies 
trasmitted back to the linux box, however the Linux box does not acknowledge 
they exist at all.

I will have to take the link down and put it back up (ifdown eth1) and 
sometimes this works. Sometimes I will get a general protection fault 022 with 
some type of "malloc" error. This was not logged, but my console was filled up 
with error messages and <00000>'s in an infinite scroll requiring a hard boot.

I have once received this error:

eth1: PCI Bus Error!  EPIC status 4259000. 

And quite a few times received messages similar to these:

eth1: Oversized Ethernet frame, status a25 4224 bytes. 
eth1: Oversized Ethernet frame, status 414c 4560 bytes.

Running epic-diag returns this (might not be relevant):
  Transmitter: slot time 512 bits, full-duplex mode.
 The word-wide EEPROM checksum is 0x4d0b.
Parsing the EEPROM of a EPIC/100:
 Station Address 00:E0:29:0A:EC:DE.
 Board name 'SMC9432TX   ', revision 222.
 Calculated checksum is 00.

And from ifconfig: (lots of errors/dropped since I recently tried the ping -f 
-s 2568 alluded to in another message).

eth1      Link encap:Ethernet  HWaddr 00:E0:29:0A:EC:DE
          inet addr:  Bcast:  Mask:
          RX packets:36285 errors:3316 dropped:5585 overruns:0
          TX packets:42221 errors:0 dropped:0 overruns:1
          Interrupt:10 Base address:0xf800 

Since I don't have these problems on the same machine using eth0 which is a 
generic NE2000 card, this epic driver seems to be the only thing that causes 
system instability.

I don't know what I can do to further track down the problem(s) but hopefully 
if others experience and document similar difficulties the driver can be 


 | To unsubscribe, send mail to Majordomo@cesdis.gsfc.nasa.gov, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name youraddress@wherever.org
 | You will be unsubscribed as speedily as possible.