[eepro100] error building netdrivers-3.1

Wilson, John John.Wilson@savvis.net
Mon Mar 25 15:04:01 2002

eepro100 group,
I'm  having some trouble building the netdrivers from the src.rpm file.
At one point this worked just fine, but I'm not sure what I'm doing wrong
this time.  I've re-booted the host and running:
	Linux sla1.dev.savvis.net 2.4.9-31 #1 Tue Feb 26 06:53:37 EST 2002
i686 unknown

Following the directions, I installed (rpm -i) the netdrivers-3.1-1.src.rpm
file and then tried to run:

# cd /usr/src/redhat
# rpm -bb SPECS/netdrivers.spec

I'm getting this error:
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.76042
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd netdrivers-3.1
+ make all
gcc -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -O6
-I/lib/modules/2.4.9-31/build/include -pipe -fno-strength-reduce
-DMODVERSIONS   -c -o pci-skeleton.o pci-skeleton.c
In file included from pci-skeleton.c:93:
linux/modules/Divas_mod.ver: No such file or directory
In file included from pci-skeleton.c:93:
linux/modules/af_netlink.ver: No such file or directory
linux/modules/af_spx.ver: No such file or directory

These .ver files are not in the
/usr/src/linux-2.4.9-31/include/linux/modules directory.  I have another
file system in which these files exist, but some of them are of zero (0)
size.  I'm not sure how they are created or why I don't have them.  I'm
assuming there is some step that I missed when I installed the 2.4.9-31

If anyone can help, it would be much appreciated... I've not been able to
determine why I don't have these missing .ver files.

thanks in advanced,
j d wilson