[eepro100] error building netdrivers-3.1

Donald Becker becker@scyld.com
Mon Mar 25 15:48:02 2002

On Mon, 25 Mar 2002, Wilson, John wrote:

> eepro100 group,
> I'm  having some trouble building the netdrivers from the src.rpm file.
> At one point this worked just fine, but I'm not sure what I'm doing wrong
> this time.  I've re-booted the host and running:
> 	Linux sla1.dev.savvis.net 2.4.9-31 #1 Tue Feb 26 06:53:37 EST 2002
> i686 unknown
> Following the directions, I installed (rpm -i) the netdrivers-3.1-1.src.rpm
> file and then tried to run:
> # cd /usr/src/redhat
> # rpm -bb SPECS/netdrivers.spec
> In file included from pci-skeleton.c:93:
> /lib/modules/2.4.9-31/build/include/linux/modversions.h:8:39:
> linux/modules/Divas_mod.ver: No such file or directory

This is the module version file from an obscure driver...

> In file included from pci-skeleton.c:93:
> /lib/modules/2.4.9-31/build/include/linux/modversions.h:17:40:
> linux/modules/af_netlink.ver: No such file or directory

This is from "Address Family netlink", the Linux "netlink" module.

> These .ver files are not in the
> /usr/src/linux-2.4.9-31/include/linux/modules directory.  I have another
> file system in which these files exist, but some of them are of zero (0)
> size.  I'm not sure how they are created or why I don't have them.  I'm
> assuming there is some step that I missed when I installed the 2.4.9-31
> kernel.

The "*.ver" files are created when you build a kernel with module
versioning enabled.  If you are missing them they were either
accidentally deleted, or you are mixing the header files from different
kernel builds.

For some distributions (e.g. Red Hat 7.2) you must install the
kernel-source package.  Confusingly the "kernel-headers" package does
not have the headers for your kernel, only the Linux-specific headers
headers needed for glibc.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993