hamachi.c problems under 2.2.14?

ted@serreyn.com ted@serreyn.com
Thu Apr 6 14:13:12 2000

I get a error when I try to insmod the module after compiling under 
2.2.14/Redhat 6.2.  I have tried the base kernel with the same result.

[root@galileo gigabit]# /sbin/insmod ./hamachi.o
./hamachi.o: unresolved symbol best_memset

Problem seems to be at line 553, in version 0.11 8/21/99 version of the code.

        /* memset(hmp, 0, sizeof(*hmp)); */

If I comment it out, it does compile and insmod correctly and appears to be 
working, although my counters look wierd.

[root@galileo gigabit]# /sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:E0:B1:04:15:DD
          inet addr:  Bcast:  Mask:
          RX packets:226050296 errors:1702047346 dropped:1351871449 
overruns:1801675112 frame:2147483647
          TX packets:1953267902 errors:1769108835 dropped:808464432 
overruns:807418163 carrier:2147483647
          collisions:808460338 txqueuelen:100
          Interrupt:10 Base address:0x4000

Ideas, fixes?  The card is a packet engines hamachi card, I can give the movel 
if someone really wants it.

Ted Serreyn
Ted Serreyn                     mailto://ted@serreyn.com/
Serreyn Network Services        http://ted.serreyn.com/
Voice: 414-438-9422             Providing Linux and Network
Fax:   414-438-9433             Monitoring, Consulting

 | To unsubscribe, send mail to Majordomo@cesdis.gsfc.nasa.gov, and within the
 |  body of the mail, include only the text:
 |   unsubscribe this-list-name youraddress@wherever.org
 | You will be unsubscribed as speedily as possible.