Troubles with a 3C905B-TX at 10Mb/s too!

Paolo Saggese
Wed Oct 13 05:27:05 1999


	I had lot's of troubles with a 3C905B-TX as well!!!

(running at 10 Mb/s, haven't had a chance to try it at 100Mb/s).

The configuration was painless, the driver loads just fine, but the
good news ends here. Transfer rates were ridicolous (network was up
but practically unusable), and there where lots of lost packets even 
pinging from/to another machine attached to the same hub/repeater 
(a DECrepeater 90T-16) and with almost 0 network load.

Even working on a telnet connection to a remote host (on the same 
LAN) was a royal pain!  Every few keystrokes, the network seem to 
hang and come back only some seconds later... and so on and on...

I have tryed almost any version of the driver, from the stock one
coming with the Mandrake 6.0 Kernel (2.2.9) to the latest available,
and different Kernels as well (including RedHat's 6.0 2.2.5, and the
kernel-2.2.13-7mdk coming with Mandrake 6.1) but have experienced no 
substantial difference either.

The situation went a little bit better using 3com's driver, but was
not really solved either.

I have also tryed to change PCI slot (that changed the IRQ line that
was assigned to the NIC), to disable the on-board sound card, etc, 
but no success.

(oh, how much do I miss the nice days when there were all those 
beautiful jumpers on the cards!!! 8-)

I have tested my 3C905B-TX on another PC with Linux, and had exactly
the same troubles. I have also installed it on a winbug 95 PC, and it
worked just fine there.

(all these PCs are in the same room, connected to the same repeater;
I have also tryed to swap net cables and wall sockets, but no change-
the problem appears always on Linux machines, no problem on windoze).

Now I have swapped in a a 10Mb/s 3c900B-TPO NIC and with it everything 
works fine with either driver.

[but since there will be an network upgrade here sooner or later, I do
need a 10/100 NIC!]

This is the config. of my PC:

 - motherboard Intel BI440ZX, 128Mb RAM (2 x 64M DIMMs);
 - CPU Intel Celeron 366;
 - 8.4Gb Quantum fireball IDE/U-DMA 66 HDD;
 - Matrox G200 AGP, (cheap one, no 3D accelerators, etc);
 - SCSI controller AdvanSys ABP9xxU "PCI Fast and Ultra SCSI Bus Master";
 - 3C905B-TX PCI NIC.

And here are some (hopefully useful) data:

[please forgive me for the length of this msg... :( ]

[pcsaggese ~]% cat /proc/interrupts
  0:    5699250          XT-PIC  timer
  1:      18676          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  es1371 
  8:          1          XT-PIC  rtc
  9:    1651745          XT-PIC  eth0
 10:         59          XT-PIC  advansys
 12:      68934          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:    3980199          XT-PIC  ide0
NMI:          0

[root@pcsaggese tmp]# cat /proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
02f8-02ff : serial(auto)
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
e800-e80f : advansys
ec00-ec7f : eth0
ef00-ef3f : es1371
ffa0-ffa7 : ide0
ffa8-ffaf : ide1          

[root@pcsaggese tmp]# lsmod
Module                  Size  Used by
3c59x                  20008   1  (autoclean)
loop                    7552   2  (autoclean)
advansys               67472   1
autofs                  8996   1  (autoclean)
nfs                    37688   1  (autoclean)
nfsd                  143768   1  (autoclean)
lockd                  30920   1  (autoclean) [nfs nfsd]
sunrpc                 53348   1  (autoclean) [nfs nfsd lockd]
nls_iso8859-1           2020   2  (autoclean)
nls_cp437               3548   1  (autoclean)
vfat                    9180   1  (autoclean)
fat                    30176   1  (autoclean) [vfat]
es1371                 23852   1
soundcore               2372   4  [es1371]

Aug  9 11:50:38 pcsaggese kernel: 3c59x.c:v0.99L 5/28/99 Donald Becker
Aug  9 11:50:38 pcsaggese kernel: eth0: 3Com 3c905B Cyclone 100baseTx at
0xec00,  00:50:04:4b:33:1a, IRQ 9
Aug  9 11:50:38 pcsaggese kernel:   8K byte-wide RAM 5:3 Rx:Tx split,
autoselect/Autonegotiate interface.
Aug  9 11:50:38 pcsaggese kernel:   Media override to transceiver type 0
Aug  9 11:50:38 pcsaggese kernel:   Enabling bus-master transmits and
whole-frame receives.
Aug  9 11:50:38 pcsaggese kernel: eth0: Media override to transceiver 0

Oh, and I got tons of these errors on system log:

Aug 15 14:39:42 pcsaggese kernel: 0<7>eth0: interrupt, status e201, latency 2
Aug 15 18:34:24 pcsaggese kernel: 7<7>eth0: interrupt, status e201, latency 50
Aug 16 13:22:25 pcsaggese kernel: t<7>eth0: interrupt, status e201, latency 2
Aug 16 23:33:14 pcsaggese kernel: i<7>eth0: interrupt, status e201, latency 2
Aug 17 02:36:52 pcsaggese kernel: t<7>eth0: interrupt, status e201, latency 2
Aug 17 05:39:11 pcsaggese kernel: r<7>eth0: interrupt, status e201, latency 3

Hope it helps!

Thanks in advance.