Vortex driver problems under RedHat 5.2

Steve Kotsopoulos steve@fywss.com
Thu Dec 31 00:02:51 1998

I'm been running RedHat 5.2 with a 3c595 as eth0 (using dhcp) and a 3c509 as
eth1 (static config) fine for about a month with the RH stock 2.0.36-1 kernel.

I recently installed the 2.1.132 kernel, and ever since then my eth0 3c595
will not configure itself via dhcp. It doesn't even look like the card is
talking to anything, because the send light on my cable modem does not blink.

I found that I could manually ifconfig the card up, but this is a temporary
solution until the dhcp lease on that IP address expires.

I have tried using the following drivers: 3c59x.c:v0.99H, 3c59x.c:v0.99E
and the 3c59x.c:v0.99E which is distributed with RedHat 5.2.
They all seem to have the same problem.

Using the v0.99H driver with VORTEX_DEBUG at 2, I get the following boot msgs:

3c59x.c:v0.99H 11/17/98 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
eth0: 3Com 3c595 Vortex 100baseTx at 0xd800,  00:a0:24:78:59:14, IRQ 11
  Internal config register is 101001b, transceivers 0xe10a.
  64K word-wide RAM 3:1 Rx:Tx split, autoselect/10baseT interface.
eth0: Overriding PCI latency timer (CFLT) setting of 32, new value is 248.

When I manually ifconfig'd the card up, I get:

eth0: Initial media type 100baseTX.
eth0: vortex_open() InternalConfig 0141001b.
eth0: vortex_open() irq 11 media status 8802.
eth0: Media selection timer tick happened, 100baseTX.
eth0: Media 100baseTX is has no link beat, 8082.
eth0: Media selection failed, now trying 10baseT port.
eth0: Media selection timer tick happened, 10baseT.
eth0: Media 10baseT has link beat, 88c0.

But when dhcp tried to config the card at boot time I did not
see any such messages.

Any idea what's wrong? Is there a fix or workaround?