New to Linux, Need help with NIC - 3COM 3c905-tx

Brian Cunningham
Fri Dec 4 12:05:24 1998


	Thanks for your suggestions.  It turns out I my problem wasn't 
associated with Linux at all.  I was having problems with Intel NIC 
card, (I think it was a clone) so I swapped it out with a 3Com card 
that was supported by Linux.  

	After trying to run a 3Com utility to check if the card was 
configured as PnP, I figured that the system BIOS was setting the 
IRQs for my PCI slots, that was once I set it to auto.  Once I did 
that, the BIOS set the 3Com card to IRQ10, rather than 0, and when 
Linux came back up, I was all set.

Thanks again for your quick response and help!

Brian Cunningham
Network Administator, CNA
Toyon Associates
Pleasant Hill, CA

On 4 Dec 98, Frank Scholten Linde enlightened us with these words:

> >  I am new to Linux and after several hair-pulling days, I finally got 
> > Red Hat 5.1 installed... Whew, they weren't kidding when they said it 
> > was difficult.
> > 
> >  Anyways, I am having trouble initializing my NIC card.  I am 
> > using a 3Com 3C905-TX (PCI) Card.  I read a bunch of info on the 
> > card and new drivers and kernels and stuff, but I just got more 
> > confused.  Hear is what I know:
> > 
> >  I am running Kernel version 2.0.35, it's trying to set the irq to 0 
> > which I get a warning that it probably won't work.
> Try to place the card in another slot, that might help (try to use the combined
> pci/isa slot.
>   I got a copy of the 
> > updated 3c59x.c file but can only find a 3c59x.o file on my system.  
> > However when I run ifconfig it does mention 3c59x.c.
> You have to compile the .c file into a .o file. Read ahead
>   I just can't 
> > figure out where this file is.  I do not have the directory structure 
> > /drivers/net as listed in the boomerang.html.  Any help would be 
> > greatly appreciated...
> IF you installed RH 5.1 out of the box it oughtta recognize the 3c905
> card without a prob (at least that always happens on the ones i installed it
> on). It normally always selects a free irq. Maybe you just don't have any free
> irq's on ya system caused by toooooooo many cards in it? You can check the
> irq's that are in use in the file /proc/interrupt. 
> There is one version i had, but i dunno wheter that was RH 5.0 or 5.1 where the
> 3c59x driver that was included in the distribution didn't work. It installed
> without a prob, ifconfig looked okie (NOT the irq 0 thingy) but there was just
> no network connection possible at all.
> In that case i downloaded the new driver source from that vortex HP as well,
> compiled it (like discribed on that page as well) replaced the old one, problem
> solved. 
> And with the "installation out of the box" you have the 3com driver compiled as
> a module, and you can find that module in /lib/modules/2.0.3x/net/. And that is
> of course then the 3x59x.o. And that is where you have to put the newly
> compiled driver then as well.
> ANyway .. hope this kinda helps. Succes
> Frank
> ----------------------------------
> Frank Scholten Linde - system/network administrator
> E-Mail: <> <>
> Date: 04-Dec-98
> Time: 08:42:01
> XFMail * Redhat 5.2 - 2.0.36 *** Get smart, get linux ***
> ----------------------------------