[tulip] Compaq Presario laptop and tulip PCMCIA card

Donald Becker becker@scyld.com
Wed Mar 6 11:13:01 2002

On 6 Mar 2002, Jesse F. Hughes wrote:

> I'm having a problem with my Presario 1600XL laptop and a "level one"
> tulip card.

Where are you getting the name "level one"?  Level One makes
transceivers, but the chip on the Linksys card is from ADMtek.

>  Currently, my sound card, the i82365 module and the
> PCMCIA card are *all* assigned IRQ 9.  Not surprisingly, this leads to
> problems.
> I'm using a 2.2.18 kernel on a slackware distribution.  I am not at
> the moment using the latest tulip modules, but rather the modules that
> came with the kernel.  
> I briefly tried the latest modules, but it's not clear what chip my
> card has.  The manfid is 0x13d1, 0xab02 (Linksys Etherfast PCM200 v2).


What does the driver report about detecting the card?

> When I run tulip-diag -p 0x800, I'm told that a recognized chip has
> been found, but does not appear to exist in I/O space.  So, I feel
> that I'm closer to the solution when I use the modules that came with
> my kernel distribution.

The diagnostic program is independent of the driver you are using.  You
should read the kernel message logs to see where the resource assignment
problem is.  There is usually a work-around that you can configure in

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993