[tulip] Compaq Presario laptop and tulip PCMCIA card

Jesse F. Hughes jesseh@cs.kun.nl
Wed Mar 6 08:28:00 2002

I'm having a problem with my Presario 1600XL laptop and a "level one"
tulip card.  Currently, my sound card, the i82365 module and the
PCMCIA card are *all* assigned IRQ 9.  Not surprisingly, this leads to

(To be sure, I was shocked when I learned that both the i82365 module
and the sound card are assigned the same interrupt.  I've tried to
change the interrupt on the i82365 module, using the irq_list option,
but the result is that the module does not load properly.  I don't see
any way to change the interrupt on the via686a driver I use for my
sound card.)

This laptop has a broken BIOS with very few options.  I can't find any
options in the BIOS that might help me here -- in particular, there is
no option to shut off PnP (thanks, Compaq!).  

When I use an NE2k PCMCIA card, it is assigned IRQ 3 and everything is
peachy (despite the apparent conflict between sound card and the
cardbus module).

I'm using a 2.2.18 kernel on a slackware distribution.  I am not at
the moment using the latest tulip modules, but rather the modules that
came with the kernel.  

I briefly tried the latest modules, but it's not clear what chip my
card has.  The manfid is 0x13d1, 0xab02 (Linksys Etherfast PCM200 v2).
When I run tulip-diag -p 0x800, I'm told that a recognized chip has
been found, but does not appear to exist in I/O space.  So, I feel
that I'm closer to the solution when I use the modules that came with
my kernel distribution.

It should be obvious that I don't know too much about hardware, so any
assistance would be appreciated.  I'd really like to fix that damn IRQ

"[R]eality has a fascinating ability to check us when we get a little too
big for our britches... Make no mistake.  There isn't a mathematician alive
today that I can't now touch, and not a mathematical career on the planet
that I can't now affect."  --James Harris, render of worlds