[tulip] Only 1 port on a 21143 Quad.

VIZADINI@lanier-europe.com VIZADINI@lanier-europe.com
Fri Jun 7 09:58:01 2002


 21143 blues all round. If -anyone- has experience getting this type of 
card to
work, and could spare the time to give some pointers on how to get it to 
it would be -much- appreciate.

Previous posts have delineated the problem; but in summary:

--> i'm trying to get a 21143 Tulip chip quad card, sitting in a Compaq 
      to work.

--> i've tried kernels 2.2.21, 2.4.2, 2.4.14, and 2.4.18. by this, i mean 
that i have 
      tried both the Tulip drivers included -with- these kernels (as 
modules as
      well as compiled-in), and i have also tried compiling the drivers 
from scyld.com
      and loading them as modules in each of these kernels.

--> the problem is always that only one port is known to the o/s; so eth0 
can be
      assigned with an address, but eth1, 2, and 3 can't.

--> my /etc/modules.conf aliases eth0-3 to tulip, and also sets a debug 
level of
      6 which produces no debug info :-/

--> pci-config finds what appears to be the 4 ports as consecutive devices 
      i take to mean that the card is not actually damaged).

--> i'm running Slackware 8.0.

and lastly

--> i'm out of ideas, on how to get this card to work.

If there is anyone on who has an idea on why it's not working and/or how 
to get it
to work, please drop me a line.

all the best,


Vafa Izadinia 
Lanier Europe B.V. 
Tel: +32 02/658.2430 
Fax: +32 02/672.7728