[tulip] asix supported, or not? 2.4 problems

Brett Dikeman brett@cloud9.net
Tue Jul 30 00:15:00 2002

At 3:27 PM -0400 7/29/02, Donald Becker wrote:

>  > cards(the V3 I believe), I get tons and tons of errors under even
>>  slight(100kB/sec) load, eventually the interface just completely
>>  stops responding to the world(anywhere from 10 minutes to an hour or
>>  two)...
>That shouldn't happen.  Check that the link partner isn't set to
>forced-full-duplex mode.

Hmm...its just a "dumb" 10/100 netgear switch...and other systems 
work fine off it; I have a netgear tulip-chip equipped system off the 
same switch, up for 32 days, only one error packet each for tx and rx.

I tried monitoring the interface's link status with the --watch 
option to miidiag, nothing ever changed, so its not flip-flopping.

According to miidiag:

Basic registers of MII PHY #1:  3000 782d 0040 61e4 01e1 41e1 0005 2001.
  The autonegotiated capability is 01e0.
The autonegotiated media type is 100baseTx-FD.
  Basic mode control register 0x3000: Auto-negotiation enabled.
  You have link beat, and everything is working OK.
  Your link partner advertised 41e1: 100baseTx-FD 100baseTx 10baseT-FD 10baseT.
    End of basic transceiver information.

I just tried forcing the card to advertise half-duplex 10BaseT...same 
result, lots of dropped packets and frame errors.

If it helps, dropped count:frame error is about a 5:1 ~ 6:1 ratio. 
Oh...and the errors are always on the rx side, tx side is always 

I have a hub I can swap into place of the switch, might give that a try.

Of course, thanks for the help so far!