[tulip] tulip v0.93 (11/7/01) problems for DS21140 quad card under RH 2.2.19

Gregg Graubins gregg@wwti.com
Sun Jan 20 04:14:01 2002

> On Wed, 9 Jan 2002, Gregg Graubins wrote:
> > [root@freedom net]# insmod -v pci-scan.o
> > Using pci-scan.o
> > Symbol version prefix 'smp_'
> > pci-scan.o: kernel-module version mismatch
> > 	pci-scan.o was compiled for kernel version 2.2.16-22
> > 	while this kernel is version 2.2.19.
> ..
> > I did notice the report about the kernel version above, but that 
> > shouldn't have any affect on trying to load the module, right?
> That's the problem -- symbol mismatches are caused by 
> compiling with the wrong kernel header files.  If you have 
> modversions enabled, you must use exactly the header files 
> for your specific kernel.

The version I tried with my 2.2.19 kernel was the one currently found at
ftp://ftp.scyld.com/pub/network/tulip.c (v0.93 11/7/2001) that says it
should work with all kernels from before 1.2.0 through the current 2.2

Orlando Rocha (Thanks Orlando!) sent me a tulip.tar that has v0.92wa
7/11/2001 in it. I compiled that one separately, tried loading it as a
module (insmod), and it worked just fine (Of course installing
pci-scan.o first).

Maybe it's just the version I originally downloaded (v0.93 11/7/2001)
being a little incompatible with 2.2.19? Or maybe it was just me. But in
any case, it's working now.

Thanks for your help (Both Donald and Orlando)!

Gregg Graubins <gregg@wwti.com>
(PGP key available)