[tulip] tulip-diag.c and tulip problems

tallpaul@speakeasy.net tallpaul@speakeasy.net
Mon Feb 4 02:12:00 2002

  First the (obvious?) question - what is up with tulip-diag.c? 
When I go to the ftp site, there is a 0 byte file. Google was not helpful
in finding me a mirrored copy either.

So I realize my problem will be harder to fix without the output of 
tulip-diag, but here we go:
My tulip (older 10Mbs card, real tulip though) was working fine
until I upgraded to RedHat 7.2. Even using a kernel/driver that I was
using with 7.1, it still doesn't work. I've tried swapping
cables for a known good one, as well as changing ports on the hub (Netgear 4 port). I've also played around with forcing it to use 10BaseT with options, and enabling level 6 debugging, but neither seems to make any noticable difference (module load messages still say the same thing, and it continues to use autosense). The card shows link and activity
(I assume that's what those LED's mean), but the hub does not register either link or activity. If I do ifconfig eth0 I see a whole bunch of transmission errors. 
Any help appreciated, and when I get a copy of tulip-diag, I'll send that output along too.