[tulip] Linksys LNE100TX v4.0 problem. (tulip.o: init_module: Device or resource busy)

Kenneth Lo klops@bigfoot.com
Thu, 21 Sep 2000 11:24:22 -0400

Okay. I have to admit I felt pretty stupid not be able
to figure this out.

Current state of affair on my box:

card: LinySys EtherFast 10/100 (LNE100TX v4.0)
kernel: 2.2.16

First of, the default tulip.c (v0.91g) didn't work 
with the card. No problem, read the linksys doc and
eventually got to scyld.com and get the latest netdriver
bundle (2.0.3 I think). The tulip.c version is v0.92.

Got tulip.c and pci-scan.c compiled with no problem.
However I've been getting 

tulip.o: init_module: Device or resource busy

error everything I'm trying to insert the module
(and yes, I did insert pci-scan.o first).

Right now the pci bus is not even detecting the
card (I'm not sure whether this makes sense or not).
Hardware-wise I _do_ see the link light is on 
from my switch, so I guess it must means the 
card is at least getting power. :-)

I tried both source RPM update and individual 
driver update as suggested on the driver update
page from scyld.com. I've also tried replacing 
the on v0.91 tulip.c file to v0.92 under my 2.2.16
kernel directory tree and tried to recompile the
kernel with tulip driver built-in, but I got a 
whole bunch of constant & declaration compile-time

I've search this archive all the way back to Feburary
and found only one reference with my problem (init_module)
that was related to older kernel (2.2.12). 

I'm out of idea now... can anyone enlighten me here?
Thanks a lot...