[tulip] Unable to get eth0 up using SMC1211TX NIC

Bob Heck heckr@ameritech.net
Sat, 16 Sep 2000 00:15:43 -0500

I am building a Linux server to place on my small home network.  My
distribution is Red Hat Linux 6.0.  I am unable to bring up the network
on either a SMC-1211TX or NetGear-FA310TX NIC.  Both of these cards are
reported to use the DEC21140 chip or its clone and the Tupip driver.
These two NICs work OK in a Windows 98 system.

I have read all of the documentation that I can find and have been
closely following the messages that appear on the Tulip mailing list.  I
have tried many of the suggestions made to no avail.  I am learning a
lot by digging deeply into the Linux system, but I have been trying to
get the NIC up and running for awhile now and I would really like to
move on to setting up the whole network.

I have included copies of some of the files pertaining to the network
and the eth0 interface below.  Also some of the error responses.

My 'linuxconf for Network Host Basic Configuration' is:

Host name = svr1

Adapter 1
[X] enabled
Config mode     (o) Manual     (  )dhcp     (  )bootp

IP Address =
Netmask    =
Net device = eth0
Kernel Module = tulip.o    debug = val

The '/etc/conf.modules' file cats out as:

alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 ncr53c8xx
alias eth0 tulip.o  debug=val
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start

When I tried the 'modprobe eth0' command, I received the following

can't locate module eth0

Cat of the '/etc/sysconfig/network-scripts/ifconfig-eth0' file produced


As expected, the 'lsmod' command returns no trace of eth0:

Module                  Size       Used by
nls_cp437             3548      1  (autoclean)
msdos                   8220      1  (autoclean)
fat                         25664    1  (autoclean) [msdos]
nfsd                      150936  8  (autoclean)
lockd                    30856    1  (autoclean) [nfsd]
sunrpc                  52356    1  (autoclean) [nfsd lockd]
ncr53c8xx            52112    3
aic7xxx                106928   7

When I issued the 'ifup eth0' command, I got the following response:

Delaying eth0 initialization.

Issuing the 'ifconfig' command displays only the local loop back

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

>From the '/proc/pci' file, it appears that the kernel is seeing the NIC

  Bus  0, device  11, function  0:
    Ethernet controller: SMC 1211 TX (rev 16).
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master
Capable.  Latency=32.  Min Gnt=32.Max Lat=64.
      I/O at 0xb800 [0xb801].
      Non-prefetchable 32 bit memory at 0xe0800000 [0xe0800000].

I tried a 'grep' of 'eth0' with the 'dmesg' command and received
nothing. However the following network related items
were observed in the '/var/log/messages' file:

Sep 12 17:47:54 svr1 network: Enabling IPv4 packet forwarding succeeded
Sep 12 17:47:57 svr1 network: Bringing up interface lo succeeded
Sep 12 17:47:57 svr1 modprobe: can't locate module eth0
Sep 12 17:47:57 svr1 ifup: Delaying eth0 initialization.
Sep 12 17:47:57 svr1 network: Bringing up interface eth0 failed
Sep 12 17:47:58 svr1 portmap: portmap startup succeeded
Sep 12 17:47:58 svr1 netfs: Mounting other filesystems succeeded


Please note that I have only attempted to bring up 'eth0' and the NIC
using modules that came with the distribution
and have not tried to do compile anything.  I really do not know how the
'eth0 interface device' is generated, but it
would appear that most things are in place.  Most other aspects of this
Linux installation appear to be working and
I am hesitant to try a reinstall.  If I did, without finding a reason
for the 'eth0' failure in this installation, the results
would probably be the same.  I would be very appreciative to anyone who
can help solve this dilemma.

Bob Heck