[tulip] - Newbie - Problems with installing the tulip.o module fo r LNE 100TX v2 -PLEASE HELP!

Keith Owens kaos@ocs.com.au
Mon, 04 Sep 2000 10:59:40 +1100

On Sun, 3 Sep 2000 17:15:15 -0500 , 
David Kramer <dkramer@interelate.com> wrote:
>However, when I run the depmod -a command from the net
>modules directory I receiving an error message back:  
>modprobe: not an ELF file
>modprobe: not an ELF file

depmod -a does not care where you run it from, it scans all the files
in all the paths listed in /etc/modules.conf.  You probably have a
couple of text files in /lib/modules/<version>, The latest modutils has
an expanded list of filenames to ignore, you might want to install it.

find /lib/modules/`uname -r` -type f | xargs file | grep -v ELF
will list all the non-ELF files.

>When I use the Depmod command seperately on the pci-scan.o it seems to work
>fine, but when I depmod tulip.o I get back an unresolved symbol(s) message.
>I dont understand what this is telling.  

depmod on a single filename will only give you partial dependency
information.  Always use depmod -a unless you really know what you are

>Now when I modprobe both the tulip and the pci-scan and then use the lsmod
>command both show up, the pci-scan is used by the tulip but the tulip isnt
>used yet.  After this I run the ifconfig command but my eth0 doesnt show.
>When I use the ifup command on eth0 I receive the following error message:
>SIOCSIFFLAGS: Resource temporarily unavailable
>SIOCADDRT: Network is down

This indicates that the device driver has not recognised the device.
Almost ceratinly this is nothing to do with depmod/insmod, it is a
driver problem.  Can't help you with the driver.