[tulip] - Newbie - Problems with installing the tulip.o module fo r LNE 100TX v2 -PLEASE HELP!

David Kramer dkramer@Interelate.com
Sun, 3 Sep 2000 17:15:15 -0500

I am new to Linux and using the tulip.o drivers.  All of my drivers and
headers files are the most recent from the SCYLD website.  I have compiled
my Tulip.c and pci-scan.c files I think correctly (used commands from the
end of the file).  However, when I run the depmod -a command from the net
modules directory I receiving an error message back:  

modprobe: not an ELF file
modprobe: not an ELF file

When I use the Depmod command seperately on the pci-scan.o it seems to work
fine, but when I depmod tulip.o I get back an unresolved symbol(s) message.
I dont understand what this is telling.  

Now when I modprobe both the tulip and the pci-scan and then use the lsmod
command both show up, the pci-scan is used by the tulip but the tulip isnt
used yet.  After this I run the ifconfig command but my eth0 doesnt show.
When I use the ifup command on eth0 I receive the following error message:

SIOCSIFFLAGS: Resource temporarily unavailable
SIOCADDRT: Network is down

 I am really not sure what else to do and Linksys tech support isnt much
help.  If anyone could provide any insight I would GREATLY appreciate it.


David Kramer