[tulip] Trying to set a NetGear FA310TX to 10Mbps--has anyone done this?

Jeff Garzik jgarzik@mandrakesoft.com
Fri, 16 Jun 2000 02:03:10 -0400

Brent Scriver wrote:
> Configuration:
> redhat 6.2 dist
> kernel version 2.3.99-pre8
> I've tried a couple of variations of the following line in conf.modules:
> options tulip options=2,5

I've got a NetGear, I'll try to force it to 10 Mbps and see what

You should also try running Donald's "mii-diag" program, which allows
you to set the media settings after the driver is loaded.

I'm concerned why autonegotiation failed though.

> I tried adding debug=6, however, it complained it didn't like the debug
> command, so some inferences from the source suggested tulip_debug, which at
> least allowed the device to be configured and started, however, I don't see
> any messages regarding its configuration.  Perhaps this doesn't go into
> /var/log/messages?  If not, where should I be looking for this information?

You need to make sure of a few things:

1) set TULIP_DEBUG in drivers/net/tulip/tulip.h to a minimum debugging
level.  I should probably do this anyway.  As it stands now, since we
are ramping up to 2.4.0, I disabled all debugging messages.  You need to
compile them back in again.

2) boot with 'debug' on the kernel command line.  ('append="debug"' in
lilo.conf, if you use LILO)

3) Make sure /etc/syslog.conf will log debug messages from the kernel

You can find Donald's mii-diag utility and also the helpful tulip-diag
utility at http://www.scyld.com/diag/   This is compatible with the
driver currently in the 2.3.x / 2.4.x kernel.

If you could send a debugging dump from tulip-diag to me personally (no
need to clutter the list), that would be great.  Something like the

	tulip-diag -mmmaaavvveef > tulip-diag.txt



Jeff Garzik              |
Building 1024            | Free beer tomorrow.
MandrakeSoft, Inc.       |