Netgear FA310TX

David Lerner
Sun Feb 6 19:49:30 2000

Sidney Antommarchi wrote:
> I have a Netgear FA310TX card in a PCI slot.  When I use the tulip
> module that came with the RH Linux 6.1
> (linuxconf.config.Networking.Client tasks.Basic host information.Adaptor
> 1.Kernel module=tulip), the machine tells me as it is booting the
> following:
>         Bringing up interface eth0 Delaying eth0 initialization.  [FAILED]
> After logging in as root, if I start netcfg and look at the interfaces I
> get:
>         lo none yes active
>         eth0 dhcp yes inactive
> If I then try to activate the interface I get the following message:
>         Delaying eth0 initialization.
> If I deactivate the interface I get the following message:
>         Operation failed.
>         eth0: unknown interface: No such device
>         eth0: error fetching interface information: Device not found
> For this reason, I tried your module as specified in
> "" but when I run
> 'insmod tulip.o" I get the following message:
>         ./tulip.o init_module:Device or resource busy
> How do I get arround this?

Use the netcfg program and edit the eth0 interface by unchecking
activate ate boot button. This should avoid aattempting to start the
tulip dirver.
A reboot may be required. Alternatively, you may be able to use the
rrmod connamd to remove the present tulip driver. Try inserting the new
tulip module with the insmod command and see it it has been accpeted by
using the "ifconfig eth0" command. Examine /var/log/messages for any
messages issued by the driver when the insmod command is used. The
ifconfig command will bring up the interface if nothing has gone wrong.

I am  not experienced using DHCP with ethernet. Is it proper for you to
specify an IP address and also use DHCP?

To unsubscribe send a message body containing "unsubscribe"