even newer info WAS: Re: new info WAS: Re: [tulip] LNE100TXversion 4.1 timeouts on tx

Erik Steffl steffl@bigfoot.com
Fri, 01 Dec 2000 22:46:05 -0800

  and I thought I was desperate yesterday!

  I did as you suggest (I also needed new kern_compat.h because of SIOC*
constants) and nothing changed.

  except of one thing: when I ran unpatched tulip.c before the card used
to lock up, then I tried patch from Dan Hollis, the card work better (no
lock ups, just problems described in previous e-mail), now, with new
tulip.c I do not need the patch anymore to get the 'better' behaviour
(no lock ups yet).

  the patch I am talking about is:

-------------- from Dan Hollis --------------
In tulip.c in the function init_media():

        case COMET:
                dev->if_port = 0;
                tp->csr6 = 0x00040000;
        case COMET:
                dev->if_port = 0;
                tp->csr6 = 0x00040000;
                outl( (inl(ioaddr + 0x88) | 0x01), ioaddr + 0x88);
------------------ cut here ------------------

------------------ code in tulip.c:v0.92p ----
        case COMET:
                dev->if_port = tp->mii_cnt ? 11 : 0;
                tp->csr6 = 0x00040000;
------------------ cut here ------------------

  while the suggested code is not in test tulip.c, the original is not
there either, it looks like the change helped to get rid of the lock-ups
(or perhaps some other change, I don't know).

  here's what I get (same as before):

tulip-diag.c:v2.04 9/26/2000 Donald Becker (becker@scyld.com)
Index #1: Found a ADMtek AL985 Centaur-P adapter at 0x6100.
 Port selection is 100mbps half duplex (Link is on)
 Transmit started, Receive started, half-duplex.
  The Rx process state is 'Waiting for packets'.
  The Tx process state is 'Idle'.
  The transmit threshold is 128.
 The Comet MAC registers are 12782000 ffffcc14 filter 0000000000000000.
 Use '-a' or '-aa' to show device registers,
     '-e' to show EEPROM contents, -ee for parsed contents,
  or '-m' or '-mm' to show MII management registers.

  It says tulip-diag-patched because it includes patch from Dan Hollis
that he says recognizes Centaur-P media, I also ran unpatched (frem web
page) and it gives the same result, except of one line (it also says
half-duplex though):

 Port selection is 100mbps-SYM/PCS 100baseTx scrambler, half-duplex.

  Carrier errors are still there:

eth0      Link encap:Ethernet  HWaddr 00:20:78:12:14:CC  
          inet addr:  Bcast:  Mask:
          RX packets:52132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34509 errors:33 dropped:0 overruns:0 carrier:33
          collisions:4538 txqueuelen:100 
          Interrupt:9 Base address:0x5000 

 and ping does not work reliably (when vnc is running):

10008 bytes from icmp_seq=748 ttl=128 time=2.2 ms
10008 bytes from icmp_seq=749 ttl=128 time=1.6 ms
10008 bytes from icmp_seq=750 ttl=128 time=3.9 ms
10008 bytes from icmp_seq=752 ttl=128 time=1.7 ms
10008 bytes from icmp_seq=753 ttl=128 time=1.6 ms
>From cert ( Frag reassembly time exceeded
10008 bytes from icmp_seq=754 ttl=128 time=1.6 ms
10008 bytes from icmp_seq=755 ttl=128 time=1.4 ms
>From cert ( Frag reassembly time exceeded
10008 bytes from icmp_seq=756 ttl=128 time=1.5 ms
10008 bytes from icmp_seq=757 ttl=128 time=1.6 ms
10008 bytes from icmp_seq=758 ttl=128 time=1.5 ms
10008 bytes from icmp_seq=759 ttl=128 time=3.7 ms
10008 bytes from icmp_seq=760 ttl=128 time=1.6 ms
10008 bytes from icmp_seq=762 ttl=128 time=1.7 ms
10008 bytes from icmp_seq=763 ttl=128 time=1.7 ms

  is there any other info I can provide? Does anybody has this card
running? I think it's the newest linksys card in this series/model (at
least that's what pitures on the web page suggest).

  and to think that I bought this card in box that says 'Tested with
Linux'. Too bad they did not say what the results of test were...


Donald Becker wrote:
> Summary: new tulip.c test version "0.92p" at
>      ftp://www.scyld.com/pub/network/test/tulip.c
> that fixes a full duplex setting bug.
> This bug only occurs the second and subsequent time the interface is
> started, thus it wasn't caught by the usual "load module, test, unload
> module" script.
> On Fri, 1 Dec 2000, Erik Steffl wrote:
> > Subject: even newer info WAS: Re: new info WAS: Re: [tulip] LNE100TX version
>     4.1  timeouts on tx
> ...
> >   I have two computers connected with crossover cable:
> Presumably in full duplex mode.
> >       linux, kernel 2.2.17,
> >       LNE100TX with driver tulip.c:v0.92 4/17/2000 with patch from Dan
> > Hollis,
> >               the patch resets the card when tx-freeze occurs (why there
> >               are these tx hung-ups in the first place?)
> Which patch, exactly?  (I *beliThis shouldn't be needed
> >   system two:
> >       Intel PRO/100 (driver name: e100bnt5.sys)
> >
> >   more info on linux side (note that it says half duplex, even though I
> > used path from Dan Hollis,the other computer thinks its full 100MB
> > duplex connection):
> ...and that's the problem!
> >           TX packets:131985 errors:2152 dropped:0 overruns:0
> > carrier:2152
> >           collisions:7425 txqueuelen:100
> Please try the latest test driver, and send a report.
> Note that this test driver *only* addresses the full duplex problem.  It
> should have no other operational change.
> Donald Becker                           becker@scyld.com
> Scyld Computing Corporation             http://www.scyld.com
> 410 Severn Ave. Suite 210               Second Generation Beowulf Clusters
> Annapolis MD 21403                      410-990-9993