D-Link DFE-500TX + Linux + netboot problems

Mark Pavlichuk MarkP@thuringowa.qld.gov.au
Sat Oct 30 21:08:49 1999

The newer machines at our site use tulip based D-link DFE500TXs (Digital
DS21140 based) which we're trying to boot diskless.  (Some of our
retired drafting PCs have already been converted to diskless Xterminals
with excellent results, and we want to experiment with the newer
machines running as diskless workstations). 

  Problem description :

  Netboot can load the Linux kernel, but once loaded the kernel tulip
driver cannot detect the network card.  No tulip driver messages of any
kind are displayed but ifconfig complains that there is no network
interface.  (I've tried making a Linux boot floppy using exactly the
same kernel and the tulip detection then works fine).

  Attempted solutions :

*  Using different packet drivers : I've tried the vendor supplied
driver, the generic DEC driver (comes with netboot) and the latest
Crynwr driver.  These can happily load the kernel, but then seem to
leave the card in a state the kernel tulip driver can't handle(?).

*  Using the latest stable Tulip driver - tulip.c (0.91)...  kernel
supplied driver was 0.89.  This upgrade didn't solve my problem

*  Using explicit packet driver settings : I hoped specifying explicit
settings on the packet driver command-line would help, but it didn't.  I
haven't tried EVERY combination of settings, but I would say I've
covered a fair subset.

*  Using etherboot to replace the need for netboot and packet drivers :
Didn't work.  I understand the etherboot tulip driver isn't complete
(only supports a subset of Tulip 24113 based cards).  I have had a look
at the source, and although I've experimented a little with basic direct
hardware programming before, my understanding of whats required in this
case seems too limited to be immediately useful.

*  Using the Generic DECchip Linux driver : Both the Generic DECchip and
Tulip Linux drivers fail in a similar way after being netbooted.

  In my travels I've discovered some other reports of similar problems
(but no solutions unfortunately) :


  Any more suggestions of things to try would be greatly appreciated.
If required I can supply tulip-diag info, although someone else has
already given similar info in one of the URLs above.  I might also be
able to assist in developing the etherboot driver if this is required
ie. testing and PERHAPS some coding (given assistance).

Thanks for your time,

Mark Pavlichuk
PC Support Officer
Thuringowa City Council