Tulip clone EEPROMs

Nicholas Edwards nicholas@gns.nicholas.net
Fri Jan 15 10:20:39 1999

Hi, thanks for everyone working on supporting both real 2141Xs and clones,
esp. Donal Becker.

After loading .90 of the driver, I was finally able to get the Macronix
98713 card working at 100baseTX-fd as well as my real 21410 Netgears.
However, only one of my two Macronix cards works. The second, upon loading
the module, recognizes the card as eth1 and it recognizes its MAC address,
but then it says, "EEPROM not present" and then it doesn't give the card
an IRQ. Later, when I try to ifconfig the card, it won't let me. I tried
putting the working Macronix card into the exact same machine, and it got
an IRQ and worked fine, so I am led to believe that the error has to do
with the specific hardware of the "broken" card. However, when I put the
"broken" card into a Windows 95 machine, it works fine. 

Is it possible that what little of an EEPROM that this Macronix card did
have somehow got corrupted. I know in tulip-diag.c, there is a function to
rewrite the EEPROMs, but I have a feeling this is only for the EEPROMs
associated with real 2141Xs. Can anyone give me advice on what to do?

Thank you,