Problem with Adaptec 4-port fast Ethernet in AlphaPC

Dong Chen
Sat Sep 19 17:45:03 1998

In my previous message:
> With a LX164, kernel 2.0.35 (the patched part looks exactly the same, though
> maybe starting from a different line number) and 0.89K tulip.c, it worked
> to some degree.  I have to compile with "reverse_probe=1" and only "eth0"
> works to some extent, ie, I could ping another machine through "eth0".
> The machine is much slower however, and none of the other ports worked.
> (The green lights are all on, which is a very positive change from before.)
> I noticed that all the ports uses different interrupt, which is not the
> case on a Pentium II machine.  Here is a shortened kernel message:

I made a mistake here, on a Pentium II, each 21140 has a seperate 
interrupt on a different PCI bus (bus 2 in one of our machines, the
normal PCI is bus 0).

> ... 

> Is kernel 2.1.122-rth18 much better in this regard?  I will try that
> tomorrow.

Kernel 2.1.122 release has the same beheavior as 2.0.35, only the first
port works.  (I compiled with tulip 0.89K build in, modules do not work
with 2.1.122 because some global symbols are missing.  No reverse probe 
in this case.  Actually reverser_probe = 1 does not work.)