Problem with Adaptec 4-port fast Ethernet in AlphaPC

Dong Chen
Fri Sep 18 20:53:18 1998

Quant-X Alpha Linux Support <> writes:
> Hi Jay !
> > The fix at the end simply makes sure that the additional register on the
> > 21152 bridge is cleared, so that it *will* pass the addresses correctly for
> > the devices behind it.
> Yes, it seems to work here, I just booted a SX nfs-rooted, I can't
> believe it, but it seems to work w/o problems.
> > Good luck, hope this is helpful. I'll continue looking into the PYXIS
> > problem over the weekend; please share any experiences you may have...
> Thanks for the patch. The PYXIS machine check problem is not very
> important for me (or am I wrong ? rth says that graceful SRM reboot
> should work, but with the 4-port card I get a machine check on reboot...).
> This is no real problem at moment here, but if you need exact reports
> contact me... I have not tried 2.1.122-rth18 without a 4-port card because
> I'm a bit stressed; maybe it's an independent problem.

With a LX164, kernel 2.0.35 (the patched part looks exactly the same, though
maybe starting from a different line number) and 0.89K tulip.c, it worked
to some degree.  I have to compile with "reverse_probe=1" and only "eth0"
works to some extent, ie, I could ping another machine through "eth0".
The machine is much slower however, and none of the other ports worked.
(The green lights are all on, which is a very positive change from before.)

I noticed that all the ports uses different interrupt, which is not the
case on a Pentium II machine.  Here is a shortened kernel message:

tulip.c:v0.89K 8/8/98
eth0: Digital DS21140 Tulip at 0xa800, 00 00 92 a7 35 f0, IRQ 18.
eth1: Digital DS21140 Tulip at 0xa000, EEPROM not present, 00 00 92 a7 35 f1,
 IRQ 25.
eth2: Digital DS21140 Tulip at 0x9800, EEPROM not present, 00 00 92 a7 35 f2,
 IRQ 29.
eth3: Digital DS21140 Tulip at 0x9000, EEPROM not present, 00 00 92 a7 35 f3,
 IRQ 33.

Is kernel 2.1.122-rth18 much better in this regard?  I will try that

Thank Jay.