DEC Tulip and hub link beat

Matt Goheen
Wed Oct 21 13:04:15 1998

This board came with an AS200 4/233 (DEC AlphaStation) that I got awhile back.  I believe
it's a 21040 based board.  Can anyone help me with the following?  I'm not a list subscriber, so
please reply to if you know anything (even if it's simply, "You need a
new hub.").

My aging and cheap 8-port Ethernet hub apparently doesn't supply link beat (or whatever
it's called).  Apparently, the tulip chip/driver on the my AS200 doesn't like that, and forces
a switch to the 10b2 media connector (from the 10bT transceiver).

I tried the latest tulip.c driver (well, pretty close to latest, I think, dated 8/8/98 I believe),
setting the options to 12, and I even tried commenting out the code that forces the media
switch -- no go.

It all works if I plug my hub into a borrowed (new/expensive) hub, then plug the AS200 into

Does the tulip chip and/or driver just REQUIRE link beat to function?  Any way to turn it
off, so that it doesn't?

    - Matt Goheen