On-board: Digital Prioris

Mauricio F. A. Walder mwalder@dirbrasil.com
Wed Nov 18 17:12:04 1998


	I've installed Linux (Debian 2.0) on a Digital Prioris 6200 MP,
with a DEC Tulip network on-board controller. I had kernel 2.0.34
compiled, with the tulip driver inside the kernel (monolith-ish). I just
couldn't get it to work...

	When I tried to run the following command: 
		route add -net xx.xx.xx.xx (network)
	I had this error:	"SIOCADDRT: Invalid argument"

	When I tried: "route add default gw yy.yy.yy.yy metric 1", I got:
"SIOCADDRT: Network is unreachable".

	During boot, when the driver loaded, I saw messages like:

   Index #4 - Media MII (#11) described by a 21142 MII PHY (3) block
   MII transceiver found at MDIO address 5, config 3100 status 7849
   eth0: Promiscuous mode enabled.

2 minutes (exact time, not kidding here) later...
   21142: 100baseTx link beat good

	Even with all this, it would not work. I was told that the board
is 10/100 Mbps, and that it is connected to a 10 Mbps hub. The link signal
is up and running, no problems here.
	I'm not sure what version of the driver it was, but it was the one
that came with the 2.0.34 kernel. The odd thing is that it detected a
Tulip 21142 chip, which was also listed in /proc/pci...

	Looking through the web, I found the page where the new driver was
announced (v0.90). I got it, recompiled the kernel with the tulip driver
as a module, and substituted it by the new driver (v0.90).
	Even now, I still have the same problem. The signs are a little
different though... The diagnostic utils (tulip-diag -m -m -v) gave me the
following info:

	DS 21143 Tulip (well, I'm sure it was 21142 before!)
	Link status: established.
	Capable of 100baseTx-FD 100baseTx 10baseT-FD 10baseT
	Able to perform Autonegotiation, negotiation complete.
	Link partner capability is 0021: 10baseT.
	 Negotiation did not complete.
	Internal autonegotiation state is 'Autonegotiation disabled'

	I had the tulip module in the /etc/modules, and the aliases in
/etc/conf.aliases. One other strage thing: when I typed "modprobe -c", I
got "alias eth0 tulip" and "alias eth0 off". WHY??? I don't have "alias
eth0 off" anywhere else in the /etc directory...

	I'm not sure if the driver is picking up the options I tried
putting on the conf.modules (I tried "options tulip options=9 debug=6, and
didn't notice any difference).

	I don't know where else to shoot anymore... I thought about:

	a) putting another Tulip card which I know works fine (Kingston
	   KNE-40BT) - the problem is that I'm not sure how the driver
	   would work with 2 Tulip cards: which one would he "choose"???

	b) trying all the options for the driver, see if any makes a

	c) I don't know what else, but I'll think of something!

	So, can anybody help me with this???

		Thanks a lot!

						Mauricio Walder