Linksys etherfast 10/100 and linux kernel 2.0.34 problems

John Watson
Mon Jul 20 15:37:02 1998

I've had luck using that card with the 0.89F tulip, which is what
I still use.  I've had strange problems getting the bastard to
work properly through my cable modem, but on the LAN it works
fine.  I've only run it at 10baseT, however, so I can't comment
on the 100baseT performance.  I've tried several times to get
help from Linksys, but they ignore me. :p

I'm not sure what the deal is with going through the cable modem,
but it can't find the gateway for some reason.  If you run
'route', it just hangs before it prints the default route
entry.  But it works on another machine in my house, an AMD.
Who knows.


scott wrote:
> Greetings,
> Has anyone out there using a linksys etherfast 10/100 card (PNIC Chipset) with Linux kernel 2.0.34?  I cannot get this setup to work.  The driver cannot find the card nor can the diagnostics unless I specify the memory address when I run tilup-diag.  And when the diagnostics run they cannot find they MII interface.   It seems that there have been changes made in the way Linux probes and identifies cards on the PCI bus since kernel 2.0.31, my current version.  I have tried the 2.034 kernel version of the driver but this did not help.  I am successfully runing this setup on Linux 2.0.31.  I also have a call into Linksys but so far no answer.
> Scott

John Watson
Software Engineer         --        STScI Archive Team