[tulip-bug] cnet, linksys, and tulip

Donald Becker becker@scyld.com
Wed, 13 Jun 2001 18:35:52 -0400 (EDT)

On Wed, 13 Jun 2001, Balazs Sallay wrote:

> I have a CNet Pro 200 card, which worked just fine with the
> dmfe.o module under Suse 7.0 and 2.2.16. I recently put there a
> Linksys LNE100TXv4 card as eth1 and tried to use it with the
> tulip driver, but the two driver didn't work at the same time. I
> suspect that the tulip driver tries to manage the CNet card on
> eth0, but it can't.

The Tulip driver does detect the Davicom chip, but you should use the
dmfe driver instead.  The dmfe driver has various ugly work-arounds for
bugs that I'm not willing to put in the critical path of the standard
Tulip driver.

> Same problems with kernel 2.4.5, though once
> in many times it looked like the tulip driver (with the absence
> of dmfe) managed the CNet card correctly. Is there a way to tell
> the tulip driver to leave the CNet card alone? 

Remove the two Davicom identification lines from tulip.c.

I will likely make that change in the standard driver source.

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Second Generation Beowulf Clusters
Annapolis MD 21403			410-990-9993