[tulip-bug] Very slow performance with FA310TX

Donald Becker becker@scyld.com
Sun, 24 Sep 2000 15:34:47 -0400 (EDT)

On Sun, 24 Sep 2000, John William wrote:

> I am having problems with a Netgear FA310TX card. Transfer rates to/from the 
> The hub indicates that the 310TX link is 100BT full duplex.
> I tried the on-board AMD PCNet32 (10BT) ethernet controller and can ftp 
> to/from the test machine at about 850K/sec. I tried a 3Com 3C509 and get the 
> same result. With the FA310TX, I only get 50-300K/sec and the transfers 
> sometimes have long stalls before they resume. Everything *works* but it's 
> deathly slow.

This sounds like either a
   Duplex mismatch
   Bad cable pairing, which works at 10BaseT but not 100baseTx

> I'm not even sure where to start looking for a problem since everything 
> works. The only hint that something might be wrong is under heavy load, the 
> 310TX starts throwing a lot of frame errors:
> eth1      Link encap:Ethernet  HWaddr 00:A0:CC:39:B1:F9
>           RX packets:530996 errors:0 dropped:0 overruns:0 frame:5735
>           TX packets:495731 errors:1 dropped:0 overruns:1 carrier:0
> Under light load, no frame errors.

Verify that that you are not forcing the duplex on this end.  That will turn
off autonegotiation, so your link partner think the link is

Donald Becker				becker@scyld.com
Scyld Computing Corporation		http://www.scyld.com
410 Severn Ave. Suite 210		Beowulf-II Cluster Distribution
Annapolis MD 21403