[tulip-bug] Very slow performance with FA310TX

John William jw2357@hotmail.com
Sun, 24 Sep 2000 16:04:39 GMT

I am having problems with a Netgear FA310TX card. Transfer rates to/from the 
machine using this card are abysmally slow.

My configuration is as follows: 2.2.17 kernel with tulip.o module, machine 
is a dual-pentium SMP machine and I'm running the SMP kernel. The test 
machine is connected to a Netgear FS105 switching hub (10/100). Other 
machines connected to the hub include two Win98 and another Linux machine. 
The hub indicates that the 310TX link is 100BT full duplex.

I tried the on-board AMD PCNet32 (10BT) ethernet controller and can ftp 
to/from the test machine at about 850K/sec. I tried a 3Com 3C509 and get the 
same result. With the FA310TX, I only get 50-300K/sec and the transfers 
sometimes have long stalls before they resume. Everything *works* but it's 
deathly slow.

I don't think there is a hardware problem because I can pull the card and 
put it in one of the Win98 machines and get about 5MB/sec with it on Windows 
Networking. I don't think it's a limitation in the test machine because it 
can consistently get ~800K/sec with a 10BT card, so it should be able to do 
at least as well with a 100BT card.

I'm not even sure where to start looking for a problem since everything 
works. The only hint that something might be wrong is under heavy load, the 
310TX starts throwing a lot of frame errors:

eth1      Link encap:Ethernet  HWaddr 00:A0:CC:39:B1:F9
          inet addr:  Bcast:  Mask:
          RX packets:530996 errors:0 dropped:0 overruns:0 frame:5735
          TX packets:495731 errors:1 dropped:0 overruns:1 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:10 Base address:0xfe00

Under light load, no frame errors.

Any suggestions?

Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at