Netgear sez: "don't use the public domain tulip driver"

Chris Worley
Wed Sep 15 14:05:11 1999

Chris Worley wrote:
> I've tried tulip.c revs .89H, .91, and .91G (I've yet to try Netgears
> .89K or Don's new .91J++).  

Now,  I've tried both Netgear's .89K and Don's .91J++ and it's
associated modules.  Same problem.

One of the windoze machines had a Winbond based 100BaseT NIC.  I saw
Don's driver for it, and swapped cards with the windoze machine.

Result: both work fine.

So, I'll leave it at that, and use the winbond NIC in the Linux gateway,
and never figure out what the problem really was.

My guess is, it has something to do with the DLink DSH-5 "hub/switch". 
I've verified that the Linux box was receiving all packets from the
network, it just failed to send or reply (sporadically).  The problem
with this conclusion is that, although I could get the Netgear NIC
working with a 10BaseT hub, I could not get it working plugged into a
Cisco DSL router (I had the same results as when plugged into the D-Link
hub/switch).  I'd need more 100BaseT hubs and switches, not available at
the location, to test this out.

Thanks to all who replied.