tulip driver error

Donald Becker becker@cesdis.gsfc.nasa.gov
Tue Dec 7 17:42:12 1999

On Tue, 7 Dec 1999, Maverick Wong wrote:

> I have a CNET PRO120 and am trying to get it to work with redhat 6.0.  I 
> tried using the tulip module that came with redhat.  It worked only 
> partially.  I could ping the card, but can't access the network that the 
> card is connected to.

That means it's not working at all.
Local packets are looped back in software and never get to the hardware.

> Thinking that it might be the modeule/driver, I tried to compile the tulip.c 
> driver in your website for smp and it gave me the following error:
> /usr/include/asm/smp.h: In function `hard_smp_processor_id':
> In file included from /usr/include/linux/smp.h:11,
>                  from /usr/include/linux/sched.h:20,
>                  from tulip.c:118:
> /usr/include/asm/smp.h:209: warning: implicit declaration of function 

You likely forgot -D__SMP__ in the compile line.

I'm putting the following lines in new driver versions:
#define __SMP__

To hopefully avoid this problem in the future.

Donald Becker
Scyld Computing Corporation, and
USRA-CESDIS,   becker@cesdis.gsfc.nasa.gov