tulip driver error

Maverick Wong mavwong@hotmail.com
Tue Dec 7 04:45:36 1999


I have a CNET PRO120 and am trying to get it to work with redhat 6.0.  I 
tried using the tulip module that came with redhat.  It worked only 
partially.  I could ping the card, but can't access the network that the 
card is connected to.  The network (ethernet) light doesn't come on for the 
port that I connect the card to.

Please tell me if there's something I might have missed out.  I am running 
redhat 6.0, running ver 2.2.5-15smp.

Thinking that it might be the modeule/driver, I tried to compile the tulip.c 
driver in your website for smp and it gave me the following error:

/usr/include/asm/smp.h: In function `hard_smp_processor_id':
In file included from /usr/include/linux/smp.h:11,
                 from /usr/include/linux/sched.h:20,
                 from tulip.c:118:
/usr/include/asm/smp.h:209: warning: implicit declaration of function 
/usr/include/asm/smp.h:209: `APIC_BASE' undeclared (first use in this 
/usr/include/asm/smp.h:209: (Each undeclared identifier is reported only 
/usr/include/asm/smp.h:209: for each function it appears in.)
/usr/include/asm/smp.h:209: `APIC_ID' undeclared (first use in this 

Desperate, I compiled the non-smp way and it worked.  It ran ok, but of 
course it wouldn't do an insmod, displaying the following error message for 

./tulip.o: kernel-module version mismatch
	./tulip.o was compiled for kernel version 2.2.5-15
	while this kernel is version 2.2.5-15smp.

Please help. Thanks.


Get Your Private, Free Email at http://www.hotmail.com