Problem with NFS and newer Tulip card

Michael Gengenbach
Mon Aug 23 15:00:15 1999


I'm not sure if this is related with the "2.2.11 and tulip.c issues"
thread, because I use a 2.2.10 kernel from the new SuSE 6.2.

Anyway I had strange problems when porting my diskless client
configuration from SuSE 5.3 (kernel 2.0.35) to SuSE 6.2 (kernel 2.2.10):

A client with a newer Tulip card will have long timeouts (10 minutes)
at boot time.

We use Compu-Shack FASTLine-II PCI 10/100 NICs which they changed
some time ago. The older ones use a 21143-PD chip from digital and
the newer ones a 21143-PD from Intel.

With the older Tulip NIC I have no problem, the client boots and works
(as far as I can tell from a couple of days installation). But the
newer NIC will get its IP address from the DHCP server, mount the
root file system from the NFS server, start booting and then will
have two large timeouts:

   1 minute in /sbin/init.d/nfs at "ldconfig -X"
   10 minutes in /sbin/init.d/xdm before starting X

the error messages I get are:

 Aug 19 22:05:38 neu kernel: nfs: server server not responding, still
 Aug 19 22:05:38 neu kernel: nfs: server server OK
 Aug 19 22:05:49 neu kernel: nfs: server server not responding, still
 Aug 19 22:05:50 neu kernel: nfs: task 13057 can't get a request slot
 Aug 19 22:06:30 neu kernel: nfs: server server OK
 Aug 19 22:06:41 neu kernel: nfs: server server OK

But after those timeouts the boot process continues and everything
works as it should. I can load large programs like Netscape or the
Java VM without a problem.

I tried driver versions 0.89h, 0.90q, 0.90z, 0.91 and 0.91g without

Any ideas what's wrong? I called SuSE and Compu-Shack without any
success. I don't know much about driver programming, but the problem seems
to be a very complex relationship between the kernel (nfs client code?),
the tulip driver and the NIC, because the same NICs worked fine with driver
0.91 under SuSE 5.3. And the older NIC still works under kernel 2.2.10.

Because we have about 50 of those NICs (mostly new ones) we are really
in need of a solution, because we need to upgrade to SuSE 6.2 soon
(because of other software).

Thanks in advance!