[realtek] 8139too-0.9.17

Andrew ablew@bigpond.net.au
Thu, 31 May 2001 04:46:33 +1000

Hi, I'm a linux newbie and I've been having a lot of trouble seeing up
my Surecom EP-320X-R  PCI card. I'm running Red Hat 7.1 and I've tried
the latest rtl8139.c and 8139too drivers. I followed the instructions
(modify the Makefile with KINCLUDES=/usr/src/linux-2.4/include) to make
8139too.o  and it worked with a few warnings.


gcc -O2 -fomit-frame-pointer -D__KERNEL__ -I/usr/src/linux-2.4/include
-DCPU=586 -march=i586  -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -pipe -DMODULE -c 8139too.c
8139too.c: In function `rtl8139_init_board':
8139too.c:743: warning: implicit declaration of function
8139too.c:743: warning: assignment makes pointer from integer without a
8139too.c: In function `mdio_read':
8139too.c:1178: warning: unused variable `i'
8139too.c:1176: warning: unused variable `mii_cmd'
8139too.c:1175: warning: unused variable `mdio_addr'
8139too.c: In function `mdio_write':
8139too.c:1221: warning: unused variable `i'
8139too.c:1220: warning: unused variable `mii_cmd'
8139too.c:1219: warning: unused variable `mdio_addr'
8139too.c: At top level:
8139too.c:1156: warning: `mdio_sync' defined but not used

Anyway I got the 8139too.o file and I tried the command

insmod 8139too.o

and I got the msg

8139too.o: unresolved symbol alloc_etherdev

is there something I'm missing? Or is my card just incompatible with
linux? Any help much appreciated. Thanks!!!