[realtek] Please help installing RealTek 8139 Card w/ CardBus on RedHat 7.1

Denis Abramov daa82@columbia.edu
Sun, 19 Aug 2001 13:24:43 -0400

Sorry to bother you all folks,
    I am having a lot of problems with the Realtek 8139 card installing on
RedHat Linux 7.1. The card which I am trying to install is a RealTek 10/100
Fast Ethernet with CardBus (32 bit PCMCIA card). I first saw that the kernel
which comes with RedHat 7.1, namely 2.4.2 already has 8139too pre-compiled
in it. Whenever I insert my card I can get an IP address from my DHCP server
but that's about it - I can only ping the card's IP address and that is the
only thing that I can ping on my network (can't even ping the DHCP server -
weird?) apart from lo. (BTW the card works fine on a WIN2K system installed
on the same computer - it's dual boot) Is it possible that the 8139too
driver was compiled w/out CARDBUS support which is giving me my problems? I
would like to re-compile it with CARDBUS support but that doesn't seem to
work because a lot of errors are thrown (probably resulting from linux/mii.h
not being there - why?). Any suggestions or ideas? So I went to try out
David Becker's driver...

    I have been able to compile two drivers from rtl8139.c which David
Becker wrote: one with the -DCARDBUS and one with regular options. The one
with regular options compied fine.

The one with -DCARDBUS compiled with:
rtl8139.c: In function 'rtl8139_detach':
rtl8139.c: warning: 'next' might be used uninitialized in this function

Should I be concerned?

    Then as it says in the instructions for creating modules I tried to test
those drivers so I tried to do "insmod pci-scan.o" and got the following
pci-scan.o: unresolved symbol pci_write_config_byte
pci-scan.o: unresolved symbol apm_register_callback
pci-scan.o: unresolved symbol kmalloc
pci-scan.o: unresolved symbol pci_find_class
pci-scan.o: unresolved symbol __check_region
pci-scan.o: unresolved symbol pc_read_config_byte
pci-scan.o: unresolved symbol pci_read_config_dword
pci-scan.o: unresolved symbol apm_unregister_callback
pci-scan.o: unresolved symbol __ioremap
pci-scan.o: unresolved symbol pci_read_config_word
pci-scan.o: unresolved symbol kfree
pci-scan.o: unresolved symbol pci_set_master
pci-scan.o: unresolved symbol pci_write_config_dword
pci-scan.o: unresolved symbol pci_write_config_word
pci-scan.o: unresolved symbol printk
pci-scan.o: unresolved symbol ioport_resource

When I try to do insmod "rtl8139.o" (the compiled driver w/out the CARDBUS
option) I get the following errors
rtl8139.o: unresolved symbol __netdev_watchdog_up
rtl8139.o: unresolved symbol eth_type_trans
rtl8139.o: unresolved symbol __kfree_skb
rtl8139.o: unresolved symbol alloc_skb
rtl8139.o: unresolved symbol init_etherdev

When I try to do insmod "realtek_cb.o" (the compiled driver w/ the CARDBUS
option) I get the following errors:
realtek_cb.o: unresolved symbol __netdev_watchdog_up
realtek_cb.o: unresolved symbol eth_type_trans
realtek_cb.o: unresolved symbol pcibios_read_config_byte
realtek_cb.o: unresolved symbol __kfree_skb

    I was wondering if anyone could give me some pointers as to what I am
doing wrong... Please help... If you need any other info to help me
troubleshhot this please tell me...
Denis Abramov